HDU-2604 Queuing

Queuing

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7344    Accepted Submission(s): 3233


 

Problem Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time.

HDU-2604 Queuing

HDU-2604 Queuing
  Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue.
Your task is to calculate the number of E-queues mod M with length L by writing a program.

 

 

Input

Input a length L (0 <= L <= 10^6) and M.

 

 

Output

Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.

 

 

Sample Input

 

3 8 4 7 4 8

 

 

Sample Output

 

6 2 1

 

 

Author

WhereIsHeroFrom

 

 

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1588 1757 2606 2276 2603 

 

 

题意:给L和M ,队伍里有f(female)和m(male)两种性别,有2^L个人在队伍中,如果子队列是fff或fmf 称为o队列,否则为e-队列

思路:

fff
fmf

·当第n位为m时 (xxm),与前n-1位无关 有 f[n]+=f[n-1]

·当第n位为f时:(xxf)
第n-1无法确定 :
··当第n-1位为m时:(xmf)
当第n-2位为m时(mmf),与 前n-3位无关, f[n]+=f[n-3]    【n-2不能为f】 
··当第n-1位为f时:(xff)
当第n-2位为m时(xmff):【n-2不能为f,n-3不能为f】
当第n-3位为m时,(mmff) , 与 前n-4位无关 f[n]+=f[n-4] 

所以考虑完第n位为m和f 的所有情况
f[n]=f[n-1]+f[n-3]+f[n-4]

f[n]           [1 0 1 1]    f[n-1]                f[3]=6
f[n-1]    =  [1 0 0 0] * f[n-2]                f[2]=4
f[n-2]        [0 1 0 0]    f[n-3]                f[1]=2
f[n-3]        [0 0 1 0]    f[n-4]     n=4时 f[0]=1 

用矩阵快速幂

代码:


#include<bits/stdc++.h>
using namespace std;

#define maxn 4
int L,M;
typedef struct Matrix{
	int m[maxn][maxn];
}Matrix;

Matrix init={6,4,2,1,0,0,0,0,0,0,0,0,0,0,0,0};
Matrix T={1,1,0,0,0,0,1,0,1,0,0,1,1,0,0,0};
Matrix mul(Matrix a,Matrix b)
{
	Matrix ans={0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0};
	for(int i=0;i<maxn;i++)
	{
		for(int j=0;j<maxn;j++)
		{
			for(int k=0;k<maxn;k++)
			{
				ans.m[i][j]+=a.m[i][k]*b.m[k][j];
				ans.m[i][j]%=M;
			}
		}
	}
	return ans;
}
Matrix qpower(Matrix a,int b)
{
	Matrix ans=init;
	while(b)
	{
		if(b%2)ans=mul(ans,a);
		b/=2;
		a=mul(a,a);
	}
	return ans;
}
int main()
{
	while(scanf("%d%d",&L,&M)!=EOF)
	{
		if(L==0){printf("%d\n",1%M);
		continue;
		}
		if(L==1)
		{
			printf("%d\n",2%M);
			continue;
		}
		if(L==2)
		{
			printf("%d\n",4%M);
			continue;
		}
		if(L==3)
		{
			printf("%d\n",6%M);
			continue;
		}
		
		Matrix ans=qpower(T,L-3);
		printf("%d\n",ans.m[0][0]%M);
		
	}
}