贪心算法解题报告(区间覆盖问题)

题目:
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations
贪心算法解题报告(区间覆盖问题)

Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1
题义:
假设海岸线是一条无限延伸的直线。陆地在海岸线的一侧,而海洋在另一侧。每一个小的岛屿是海洋上的一个点。雷达坐落于海岸线上,只能覆盖d距离,所以如果小岛能够被覆盖到的话,它们之间的距离最多为d。题目要求计算出能够覆盖给出的所有岛屿的最少雷达数目。
思路:对于每个小岛,我们可以将每一个雷达所在位置投影到x轴上。问题转化为如何用尽可能少的点覆盖这些区间。先将所有区间按照左端点大小排序。若两区间重合只需要放两个,若两区间互不重合,则需要两个。如果一个区间完全包含于另外一个区间,我们需要更新区间的右端点;如果两个区间不相交,我们需要增加点并更新右端点。
代码:

#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
struct Point
{
    double x;
    double y;
}m[1000];
int cmp(const void *a, const void *b)
{
    return (*(Point *)a).x>(*(Point *)b).x?1:-1;
}
int main()
{
    int n,d;
    int num=1;
    while(cin>>n>>d)
    {
        int k=1;
        if(n==0&&d==0) break;
        for(int i=0;i<n;i++)
        {
            int x,y;
            cin>>x>>y;
            if(y>d)
            {
                k=-1;
            }
            double t=sqrt(d*d-y*y);
            m[i].x=x-t;
            m[i].y=x+t;
        }
        if(k!=-1)
        {
            qsort(m,n,sizeof(m[0]),cmp);
            double s=m[0].y;
            for(int i=1;i<n;i++)
            {
                if(m[i].x>s)
                {
                    k++;
                    s=m[i].y;
                }
                else if(m[i].y<s)
                {
                    s=m[i].y;
                }
            }
        }
        cout<<"Case "<<num<<':'<<' '<<k<<endl;
        num++;
    }
}