L2-2 重排链表 (25 分)

L2-2 重排链表 (25 分)

给定一个单链表 L​1​​→L​2​​→⋯→L​n−1​​→L​n​​,请编写程序将链表重新排列为 L​n​​→L​1​​→L​n−1​​→L​2​​→⋯。例如:给定L为1→2→3→4→5→6,则输出应该为6→1→5→2→4→3。

输入格式:

每个输入包含1个测试用例。每个测试用例第1行给出第1个结点的地址和结点总个数,即正整数N (≤10​5​​)。结点的地址是5位非负整数,NULL地址用−1表示。

接下来有N行,每行格式为:

Address Data Next

其中Address是结点地址;Data是该结点保存的数据,为不超过10​5​​的正整数;Next是下一结点的地址。题目保证给出的链表上至少有两个结点。

输出格式:

对每个测试用例,顺序输出重排后的结果链表,其上每个结点占一行,格式与输入相同。

输入样例:

00100 6
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

输出样例:

68237 6 00100
00100 1 99999
99999 5 12309
12309 2 00000
00000 4 33218
33218 3 -1
#include <iostream>
#include <algorithm>
#include <string.h>
#include <string>
#include <math.h>
#include <list>
using namespace std;

const int MAX = 100005;

struct node{
	int key;
	int next;
};

node a[MAX];

int b[MAX],c[MAX];

int main(){
	
	int n,m;
	cin>>n>>m;
	
	int address;
	
	for(int i=0;i<m;i++){
		cin>>address;
		cin>>a[address].key;
		cin>>a[address].next;
	}
	
	int cnt = 0;
	
	int k1 = 0,k2 = 0;
	for(int i=n;i!=-1;i=a[i].next){
		cnt++;
		if(cnt <= m / 2){
			b[k1++] = i;	
		}
		else{
			c[k2++] = i;
		}
	}
	
	if(k1 == k2){
		
		printf("%05d %d ",c[k2-1],a[c[k2-1]].key);
		for(int i=0;i<k1;){
			
			printf("%05d\n",b[i]);
			printf("%05d %d ",b[i],a[b[i]].key);
			i++;
			
			if(i>=k1){
				break;
			}
			
			printf("%05d\n",c[k2-1-i]);
			printf("%05d %d ",c[k2-1-i],a[c[k2-1-i]].key);
		}
		printf("-1");
	}
	else{
		
		int i=0;
		while(k1 || k2){
			
			if(k2){
				k2--;
				printf("%05d %d ",c[k2],a[c[k2]].key);
				if(k2>0)
					printf("%05d\n",b[i]);
				else{
					printf("-1");
					break;
				}
			}
			
			if(i<k1){
				
				printf("%05d %d ",b[i],a[b[i]].key);
				printf("%05d\n",c[k2-1]);
				i++;
			}
		}	
	}
	
	return 0;
}

 

L2-2 重排链表 (25 分)

有个测试点一直wa!