PAT (Advanced Level) Practice — 1153 Decode Registration Card of PAT (25 分)

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/1071785190929788928

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

 

#include<bits/stdc++.h>
using namespace std;
struct Stu{
	string s;
	int sc;
	bool f;
}stu[10010];
struct node{
	int id;
	int sum;
};
bool cp(int x,int y)
{
	if(stu[x].sc!=stu[y].sc)
	return stu[x].sc>stu[y].sc;
	return stu[x].s<stu[y].s;
}
bool cp2(node x,node y)
{
	if(x.sum!=y.sum)
	return x.sum>y.sum;
	return x.id<y.id;
}
map<string,int> mapp;
int main(){
	int n,m;
	cin>>n>>m;
	int aa[11111],bb[11111],tt[11111];
	int er[1111][2];
	memset(er,0,sizeof(er));
	int a1=0,b1=0,t1=0;
	for(int i=0;i<n;i++){
		cin>>stu[i].s>>stu[i].sc;
		if(stu[i].s[0]=='A')
		aa[a1++]=i;
		else if(stu[i].s[0]=='B')
		bb[b1++]=i;
		else tt[t1++]=i;
		int zs=(stu[i].s[1]-'0')*100+(stu[i].s[2]-'0')*10+(stu[i].s[3]-'0');
		er[zs][0]++;
		er[zs][1]+=stu[i].sc;
	}
	sort(aa,aa+a1,cp);
	sort(bb,bb+b1,cp);
	sort(tt,tt+t1,cp);
	int bz;
	string ss;
	for(int cnt=1;cnt<=m;cnt++){
		cin>>bz>>ss;
		printf("Case %d: %d %s\n",cnt,bz,ss.c_str());
		if(bz==1){
			int f=0;
			if(ss[0]=='A')
			{
				f=a1;
				for(int i=0;i<a1;i++)
				printf("%s %d\n",stu[aa[i]].s.c_str(),stu[aa[i]].sc);
				//cout<<stu[aa[i]].s<<" "<<stu[aa[i]].sc<<endl;
			}
			else if(ss[0]=='B')
			{
				f=b1;
				for(int i=0;i<b1;i++)
				printf("%s %d\n",stu[bb[i]].s.c_str(),stu[bb[i]].sc);
				//cout<<stu[bb[i]].s<<" "<<stu[bb[i]].sc<<endl;
			}
			else{
				f=t1;
				for(int i=0;i<t1;i++)
				printf("%s %d\n",stu[tt[i]].s.c_str(),stu[tt[i]].sc);
				//cout<<stu[tt[i]].s<<" "<<stu[tt[i]].sc<<endl;
			}
			if(!f){
				printf("NA\n");
			}
		}else if(bz==2){
			int num=0;
			int zs=(ss[0]-'0')*100+(ss[1]-'0')*10+(ss[2]-'0');
			num=er[zs][0];
			if(!num){
				printf("NA\n");
				continue;
			}
			printf("%d %d\n",num,er[zs][1]);
		}else if(bz==3){
			node lss[1111];
			bool num=0;
			for(int i=0;i<=999;i++)
			lss[i].id=i,lss[i].sum=0;
			for(int i=0;i<n;i++)
			{
				if(ss==stu[i].s.substr(4,6))
				{
					int zs=(stu[i].s[1]-'0')*100+(stu[i].s[2]-'0')*10+(stu[i].s[3]-'0');
					lss[zs].sum++;
					num=1;
				}
			}
			sort(lss,lss+1000,cp2);
			for(int i=0;i<=999;i++)
			{
				if(lss[i].sum==0)break;
				if(lss[i].id>=100)
				printf("%d %d\n",lss[i].id,lss[i].sum);
				//cout<<lss[i].id<<" "<<lss[i].sum<<endl;
				else if(lss[i].id>=10)
				printf("0%d %d\n",lss[i].id,lss[i].sum);
			   // cout<<"0"<<lss[i].id<<" "<<lss[i].sum<<endl;
				else 
				printf("00%d %d\n",lss[i].id,lss[i].sum);
				//cout<<"00"<<lss[i].id<<" "<<lss[i].sum<<endl;
			}
			if(!num){
				printf("NA\n");
			}
		}
	}
	return 0;
} 

PAT (Advanced Level) Practice — 1153 Decode Registration Card of PAT (25 分)

 

下面的代码第三个测试点一直超时。。。。。。

PAT (Advanced Level) Practice — 1153 Decode Registration Card of PAT (25 分)

#include<bits/stdc++.h>
using namespace std;
struct Stu{
	string s;
	int sc;
	bool f;
}stu[10010];
bool cmp(Stu x,Stu y){
	if(x.sc!=y.sc){
		return x.sc>y.sc;
	} 
	if(x.s!=y.s){
		return x.s<y.s;
	}
}
map<string,int> mapp;
int main(){
	int n,m;
	scanf("%d%d",&n,&m);
	for(int i=0;i<n;i++){
		cin>>stu[i].s>>stu[i].sc;
	}
	sort(stu,stu+n,cmp);
	int bz;
	string ss;
	for(int cnt=1;cnt<=m;cnt++){
		cin>>bz>>ss;
		printf("Case %d: %d %s\n",cnt,bz,ss.c_str());
		if(bz==1){
			bool f=0;
			for(int i=0;i<n;i++){
				if(ss==stu[i].s.substr(0,1)){
					f=1;
					printf("%s %d\n",stu[i].s.c_str(),stu[i].sc);
				}
			}
			if(!f){
				printf("NA\n");
				continue;
			}
		}else if(bz==2){
			int num=0,gra=0;
			for(int i=0;i<n;i++){
				if(ss==stu[i].s.substr(1,3)){
					num++;
					gra+=stu[i].sc;
				}
			} 
			if(!num){
				printf("NA\n");
				continue;
			}
			printf("%d %d\n",num,gra);
		}else if(bz==3){
			for(int i=0;i<n;i++){
				if(ss==stu[i].s.substr(4,6)){
					mapp[stu[i].s.substr(1,3)]+=1;
				}
			}
			int num=0;
			for(int i=0;i<n;i++){
				if(mapp[stu[i].s.substr(1,3)]){
					printf("%s %d\n",stu[i].s.substr(1,3).c_str(),mapp[stu[i].s.substr(1,3)]);
					mapp[stu[i].s.substr(1,3)]=0;
					num++;
				}
			}	
			if(!num){
				printf("NA\n");
				continue;
			}
		}
	}
	return 0;
}