甲级PAT 1152 Google Recruitment (20 分)(暴力求解)

1152 Google Recruitment (20 分)

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

甲级PAT 1152 Google Recruitment (20 分)(暴力求解)

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

题目要求 

在一串数字中找到连续的n个数为素数,如果没找到输出404

解题思路

直接从头开始枚举长度为n的数就可以了,判断是否为素数,这里利用了substr(pos,len)将字符串截取,然后stoi将字符串转化为int类型

完整代码

#include<bits/stdc++.h>
using namespace std;

bool isprime(int x){
  if(x<=1) return false;
	for(int i=2;i*i<=x;i++){
		if(x%i==0) return false;
	}
	return true;
}

int main(){
	int l,n,i;
	string s,temp;
	int num;
	cin>>l>>n>>s;
	for(i=0;i<=l-n;i++){
		temp=s.substr(i,n);
		num=stoi(temp);
		if(isprime(num)){
			cout<<temp; //不能输出num,因为例如0001则输出1 
			return 0;
		}
	}
   cout<<404<<endl;
	
	return 0;
}