PAT-A1029 Median 题目内容及题解

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

题目大意

题目给定两个递增的整数序列,要求找出它们的中值并输出。

解题思路

  1. 本题内存空间极少,只有1.5M,因此只读入第一个序列,对第二个序列采取边对比边读入的方式;
  2. 输出结果并返回0值。

代码

#include<stdio.h>
#define maxn 200010

int main(){
    int n1,n2,mid;
    int a[maxn],b;
    int i,j,INF=0x7fffffff;
    scanf("%d",&n1);
    for(i=0;i<n1;i++){
        scanf("%d",&a[i]);
    }
    a[i]=INF;
    scanf("%d",&n2);
    mid=(n1+n2+1)/2;
    n2--;
    i=0,j=0;
    scanf("%d",&b);
    while(--mid){
        if(a[i]<b){
            i++;
        }else{
            if(j<n2){
                scanf("%d",&b);
                j++;
            }else{
                b=INF;
            } 
        }
    }
    printf("%d\n",a[i]<b?a[i]:b);
    return 0;
}

运行结果

PAT-A1029 Median 题目内容及题解