PAT-A1028 List Sorting 题目内容及题解

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60

000007 James 85

000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

题目大意

题目给定一组数据,并根据题目要求排序并输出。

解题思路

  1. 排序输出并返回0值即可。

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 100010
struct Student{
    int id,grade;
    char name[10];
}stu[maxn];

bool cmp1(Student a,Student b){
    return a.id<b.id;
}

bool cmp2(Student a,Student b){
    int i=strcmp(a.name,b.name);
    if(i!=0){
        return i<0;
    }else{
        return a.id<b.id;
    }
}

bool cmp3(Student a,Student b){
    if(a.grade!=b.grade){
        return a.grade<b.grade;
    }else{
        return a.id<b.id;
    }
}


int main(){
    int N,C;
    int i;
    scanf("%d%d",&N,&C);
    for(i=0;i<N;i++){
        scanf("%d %s %d",&stu[i].id,&stu[i].name,&stu[i].grade);
    }
    if(C==1){
        sort(stu,stu+N,cmp1);
    }else if(C==2){
        sort(stu,stu+N,cmp2);
    }else{
        sort(stu,stu+N,cmp3);
    }
    for(i=0;i<N;i++){
        printf("%06d %s %d\n",stu[i].id,stu[i].name,stu[i].grade);
    }
    return 0;
}

运行结果

PAT-A1028 List Sorting 题目内容及题解