PAT-A1032 Sharing 题目内容及题解

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

PAT-A1032 Sharing 题目内容及题解

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

题目大意

为了节省空间,我们可以在储存单词时使用相同的子链表储存共同后缀。题目给出两个链表,找出并输出公共后缀的起始位置或返回-1。

解题思路

  1. 在链表采用静态链表,储存时加一个数据域,存储是否被访问过;
  2. 第一个链表遍历同时修改访问位;
  3. 遍历第二个链表时遇到访问过的情况则表明找到公共后缀的起点,如到末尾也未找到说明没有公共后缀;
  4. 输出结果并返回0值。

代码

#include<stdio.h>
#define maxn 100010

struct Node{
    int vis;
    int next;
}node[maxn];

int main(){
    int S1,S2,N;
    int a,c;
    char b;
    scanf("%d%d%d",&S1,&S2,&N);
    while(N--){
        scanf("%d %c %d",&a,&b,&c);
        node[a].vis=0;
        node[a].next=c;
    }
    while(S1!=-1){
        node[S1].vis=1;
        S1=node[S1].next;
    }
    while(S2!=-1&&node[S2].vis==0){
        S2=node[S2].next;
    }
    if(S2==-1){
        printf("-1\n");
    }else{
        printf("%05d\n",S2);
    }
    return 0;
}

运行结果

PAT-A1032 Sharing 题目内容及题解