《算法笔记》4.2小节——算法初步->哈希 问题 C: Be Unique

                                        问题 C: Be Unique

题目描述

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

输入

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

输出

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

样例输入

7 5 31 5 88 67 88 17
5 888 666 666 888 888

样例输出

31
None

实现代码:

#include<cstdio>
#include<cstring>
int a[100001],hashTable[10001]={0};
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
        hashTable[a[i]]++;
    }
    int ans=0;
    for(int i=0;i<n;i++)
    {
        if(hashTable[a[i]]==1)
        {
            ans=a[i];
            break;
        }
    }
    if(ans==0) printf("None");
    else printf("%d\n",ans);
    return 0;
}

 

结果如下:

《算法笔记》4.2小节——算法初步->哈希 问题 C: Be Unique