PAT-A1075 PAT Judge 题目内容及题解

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​^4​​), the total number of users, K (≤5), the total number of problems, and M (≤10​^5​​), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

题目大意

题目给出一个提交列表,根据这个提交列表输出成绩排名。

其中,根据总分计算排名,所有具有相同总分的用户获得相同的排名;s[i]是第i题的部分得分。如果用户从未提交问题的解决方案,则必须在相应位置输出“-”。如果用户为解决一个问题提交了多个解决方案,则计算最高分。排名必须按非降序排列。对于具有相同分数的用户,必须按照完全解决的问题的数量进行非递增排序。如果仍然有平局,则必须按id的递增顺序输出。对于那些从未提交过任何可以通过编译器的解答的人,或者从未提交过任何解答的人,它们不能显示在ranklist中。可以保证至少有一个用户可以显示在排名表上。

解题思路

  1. 使用结构体储存考生信息;
  2. 对每个提交更新相对应的结构体信息;
  3. 将其按照题目要求排序并确认最终排名;
  4. 输出结果并返回零值。

代码

#include<cstdio>
#include<algorithm>
using namespace std;
 
#define maxn 10010
struct Student{
    int id;
    int score[10];
    int score_v[10];
    int totalscore;
    int vivid;
    int rank;
    int perfect_solved;
}stu[maxn];
 
int N,K,M;
int p[10];

bool cmp(Student a,Student b){
    if(a.vivid!=b.vivid){
        return a.vivid>b.vivid;
    }else if(a.totalscore!=b.totalscore){
        return a.totalscore>b.totalscore;
    }else if(a.perfect_solved!=b.perfect_solved){
        return a.perfect_solved>b.perfect_solved;
    }else{
        return a.id<b.id;
    }
}

void Init(){
    int i,j;
    int id,p_id,score;
    scanf("%d%d%d",&N,&K,&M);
    for(i=1;i<=N;i++){
        stu[i].id=i;
        stu[i].perfect_solved=0;
        stu[i].totalscore=0;
    }
    for(i=1;i<=K;i++){
        scanf("%d",&p[i]);
    }
    for(i=0;i<M;i++){
        scanf("%d%d%d",&id,&p_id,&score);
        stu[id].score_v[p_id]=1;
        if(score>=0){
            stu[id].vivid=1;
            if(score>stu[id].score[p_id]){
                stu[id].score[p_id]=score;
            }
        }
    }
    for(i=1;i<=N;i++){
        for(j=1;j<=K;j++){
            stu[i].totalscore+=stu[i].score[j];
            if(stu[i].score[j]==p[j]){
                stu[i].perfect_solved++;
            }
        }
    }
    return;
}

int main(){
    int i,j,num=1;
    Init();
    sort(stu+1,stu+N+1,cmp);
    stu[1].rank=1;
    for(i=2;i<=N;i++){
        if(stu[i].vivid==0){
            break;
        }
        num++;
        if(stu[i].totalscore==stu[i-1].totalscore){
            stu[i].rank=stu[i-1].rank;
        }else{
            stu[i].rank=i;
        }
    }
    for(i=1;i<=num;i++){
        printf("%d %05d %d",stu[i].rank,stu[i].id,stu[i].totalscore);
        for(j=1;j<=K;j++){
            if(stu[i].score_v[j]==1){
                printf(" %d",stu[i].score[j]);
            }else{
                printf(" -");
            }
        }
        printf("\n");
    }
    return 0;
}

运行结果

PAT-A1075 PAT Judge 题目内容及题解