数据结构实验之链表七:单链表中重复元素的删除

数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

Input

第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。

Output

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

Sample Input

10
21 30 14 55 32 63 11 30 55 30

Sample Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

在这里插入代码片#include <stdio.h>
#include <stdlib.h>
struct st
{
    int data;//定义数据域
    struct st *next;//定义指针域
};
struct st *cr1(int n)       //建逆序表
   { int i;
    struct st*head,*p;
    head=(struct st*)malloc(sizeof(struct st));
    head->next=NULL;
    for(i=1;i<=n;i++)
    {
        p=(struct st *)malloc(sizeof(struct st));
        scanf("%d",&p->data);
        p->next=head->next;
        head->next=p;
    }
    return head;
};
int del(struct st*h,int n)        //删除n个结点中的重复结点。
{
    struct st*p,*q,*z;           
    p=h->next;         //p指向第一个点
    while(p)
    {
        z=p;
        q=z->next;   
        while(q)   
     {if(p->data==q->data)
     {
         z->next=q->next;
         q=z->next;
         n--;

     }
     else {z=z->next;q=q->next;}


    }
     p=p->next;
    }
    return n;
}
void pr(struct st *h)
{
    struct st*p;
    int n=0;
    p=h->next;
    while(p)
    {n++;
    if(n==1)
    printf("%d",p->data);
    else printf(" %d",p->data);
    p=p->next;

    }

    printf("\n");

}
int main()
{
    int n,s;
    struct st *h;
    scanf("%d",&n);
    h=cr1(n);
    printf("%d\n",n);
    pr(h);
    s=del(h,n);
    printf("%d\n",s);
    pr(h);
    return 0;
}

数据结构实验之链表七:单链表中重复元素的删除