HDU Counting Sheep

链接http://acm.hdu.edu.cn/diy/contest_showproblem.php?pid=1002&cid=34750

Problem Description

A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.

HDU Counting Sheep



Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.


Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.

Input

The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.

Output

For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints
0 < T <= 100
0 < H,W <= 100

Sample Input

2
4 4
#.#.
.#.#
#.##
.#.#
3 5
###.#
..#..
#.###

Sample Output

6
3

BFS模板题,遇到#,将#能走到的位置变成点,看有多少块区域被隔开

HDU Oil Deposits跟这题一样,只是搜索方向增加了4个

链接http://acm.hdu.edu.cn/diy/contest_showproblem.php?pid=1011&cid=34750

 

#include<iostream>
#include<queue>
using namespace std;
int n,m;
char map[110][110];
int dir[4][2] = {0,1,0,-1,1,0,-1,0};
struct node{
	int x,y;
};
using namespace std;
void bfs(int x,int y){
	queue<node>q;
	q.push({x,y});
	map[x][y]='.';
	while(!q.empty()){
		int x=q.front().x,y=q.front().y;
		q.pop();
		for(int i=0;i<4;i++){
			int xx=x+dir[i][0],yy=y+dir[i][1];
			if(xx>=0&&xx<n&&yy>=0&&yy<m&&map[xx][yy]=='#')
			{
				map[xx][yy]='.';
				q.push({xx,yy});
			}
		}
	}
} 
int main(){
	int t;
	cin>>t;
	while(t--){
		cin>>n>>m;
		for(int i=0;i<n;i++)
		cin>>map[i];
		int sum=0;
		for(int i=0;i<n;i++)
		 for(int j=0;j<m;j++){
		 	if(map[i][j]=='#'){
		 		sum++;
		 		bfs(i,j);
		 	}
		 }
		 cout<<sum<<endl;
	}
	return 0;
}