Romantic 扩展欧几里得

Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7383    Accepted Submission(s): 3119


Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei

Romantic 扩展欧几里得

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 

Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.
 

Sample Input

77 51
10 44
34 79
 

Sample Output

2 -3
sorry
7 -3
 

Author
yifenfei
 

Source
 

Recommend
lcy

这题是 输入a,b    解这个方程X*a + Y*b = 1 注意x要是非负数



#include<iostream>
#include<math.h>
#include<algorithm>
using namespace std;
typedef long long  ll; 
int gcd(int a,int b)
{
return b==0?a:gcd(b,a%b);
}
bool is_prime[11000];
int prime[110000];


void prim(int n)
{
int p=0;
fill(is_prime,is_prime+n,true);
is_prime[0]=is_prime[1]=false;
for(int i=2;i<=n;i++)
{
if(is_prime[i])
{
prime[p++]=i;
for(int j=2*i;j<=n;j+=i)
{
is_prime[j]=false;
}
}
}
}


bool is_pri(int n)
{
for(int i=2;i*i<=n;i++)
{
if(!(n%i)) return false;
}
return n!=1;
}
ll e_gcd(ll a,ll b,ll &x,ll &y)
{
if(b==0)

x=1;y=0;
return a;
}
ll ans=e_gcd(b,a%b,x,y);
ll t=x;
x=y;
y=t-a/b*y;
return ans;
}


ll a,b;
int main()
{
while(cin>>a>>b)
{
ll x,y;
if(gcd(a,b)!=1)
{
cout<<"sorry"<<endl;
continue;
}
ll ans=e_gcd(a,b,x,y);
while(x<=0)
{
x+=b;
y-=a;

cout<<x<<" "<<y<<endl;
}
return 0;
}

人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想。