isis 

 

 
r0#show running-config
Building configuration...
 
Current configuration : 869 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r0
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
clns routing
no ftp-server write-enable
!
!
!
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.0
 ip router isis r0
 isis circuit-type level-1
!
interface FastEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 ip router isis r0
 duplex auto
 speed auto
 isis circuit-type level-1
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router isis r0
 net 48.0001.0000.0000.0001.00
 is-type level-1
!
ip http server
ip classless
!
!
!
!
!
control-plane
!
!
line con 0
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
!
end
         
r0#
r0#
 
r1#show run
r1#show running-config
Building configuration...
 
Current configuration : 810 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
clns routing
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.2.2 255.255.255.0
 ip router isis r1
 duplex auto
 speed auto
 isis circuit-type level-1
!
interface FastEthernet1/0
 ip address 192.168.3.1 255.255.255.0
 ip router isis r1
 duplex auto
 speed auto
 isis circuit-type level-2-only
!
router isis r1
 net 48.0001.0000.0000.0002.00
!
ip http server
ip classless
!
!
!
!
!
control-plane
!
!
line con 0
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
!
end
 
r1#
 
r2#show run
r2#show running-config
Building configuration...
 
Current configuration : 810 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
clns routing
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.4.1 255.255.255.0
 ip router isis r2
 duplex auto
 speed auto
 isis circuit-type level-1
!
interface FastEthernet1/0
 ip address 192.168.3.2 255.255.255.0
 ip router isis r2
 duplex auto
 speed auto
 isis circuit-type level-2-only
!
router isis r2
 net 49.0002.0000.0000.0003.00
!
ip http server
ip classless
!
!
!
!
!
control-plane
!
!
line con 0
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
!
end
 
r2#
r3#show run
r3#show running-config
Building configuration...
 
Current configuration : 869 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r3
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
clns routing
no ftp-server write-enable
!
!
!
!
interface Loopback0
 ip address 192.168.5.1 255.255.255.0
 ip router isis r3
 isis circuit-type level-1
!
interface FastEthernet0/0
 ip address 192.168.4.2 255.255.255.0
 ip router isis r3
 duplex auto
 speed auto
 isis circuit-type level-1
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router isis r3
 net 49.0002.0000.0000.0004.00
 is-type level-1
!
ip http server
ip classless
!
!
!
!
!
control-plane
!
!
line con 0
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4