中小型服务器网络架构

中小型服务器网络架构

LSW1、LSW2、LSW3(S3700):

只需要更改接口1的vlan即可

[Huawei]vlan batch 10 to 40

[Huawei]interface Eth0/0/1

[Huawei-Ethernet0/0/1]port link-type access

[Huawei-Ethernet0/0/1]port default vlan 10

[Huawei-port-group-1]group-member e0/0/2 e0/0/3 

[Huawei-port-group-1]port link-type trunk

[Huawei-port-group-1]port trunk allow-pass vlan all

LSW4(S3700):

[Huawei]vlan batch 10 to 40

[Huawei]interface Eth0/0/1

[Huawei-Ethernet0/0/1]port link-type access

[Huawei-Ethernet0/0/1]port default vlan 40

[Huawei]interface Eth0/0/2

[Huawei-Ethernet0/0/2]port link-type access

[Huawei-Ethernet0/0/2]port default vlan 40

[Huawei-port-group-1]group-member e0/0/3 e0/0/4

[Huawei-port-group-1]port link-type trunk

[Huawei-port-group-1]port trunk allow-pass vlan all

LSW5(S5700):

<Huawei>display current-configuration

vlan batch 10 to 40 50 60

#

interface Vlanif10

 ip address 192.168.10.252 255.255.255.0

 vrrp vrid 10 virtual-ip 192.168.10.254

 vrrp vrid 10 priority 120

#

interface Vlanif20

 ip address 192.168.20.252 255.255.255.0

 vrrp vrid 20 virtual-ip 192.168.20.254

#

interface Vlanif30

 ip address 192.168.30.252 255.255.255.0

 vrrp vrid 30 virtual-ip 192.168.30.254

#

interface Vlanif40

 ip address 192.168.40.252 255.255.255.0

 vrrp vrid 40 virtual-ip 192.168.40.254

#

interface Vlanif50

 ip address 192.168.50.2 255.255.255.0

#

interface Vlanif60

 ip address 192.168.60.2 255.255.255.0

#

interface GigabitEthernet0/0/1

 port link-type trunk

 port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/2

 port link-type trunk

 port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/3

 port link-type trunk

 port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/4

 port link-type trunk

 port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/5

 port link-type trunk

 port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/6

 port link-type access

 port default vlan 50

#

interface GigabitEthernet0/0/7

 port link-type access

 port default vlan 60

#

ospf 1

 area 0.0.0.0

  network 192.168.50.0 0.0.0.255

  network 192.168.60.0 0.0.0.255

  network 192.168.40.0 0.0.0.255

  network 192.168.30.0 0.0.0.255

  network 192.168.20.0 0.0.0.255

  network 192.168.10.0 0.0.0.255

#

port-group 1

 group-member GigabitEthernet0/0/1

 group-member GigabitEthernet0/0/2

 group-member GigabitEthernet0/0/3

 group-member GigabitEthernet0/0/4

 

LSW6(S5700):

<Huawei>display current-configuration

#

interface Vlanif10

 ip address 192.168.10.253 255.255.255.0

 vrrp vrid 10 virtual-ip 192.168.10.254

#

interface Vlanif20

 ip address 192.168.20.253 255.255.255.0

 vrrp vrid 20 virtual-ip 192.168.20.254

#

interface Vlanif30

 ip address 192.168.30.253 255.255.255.0

 vrrp vrid 30 virtual-ip 192.168.30.254

 vrrp vrid 30 priority 120

#

interface Vlanif40

 ip address 192.168.40.253 255.255.255.0

 vrrp vrid 40 virtual-ip 192.168.40.254

 vrrp vrid 40 priority 120

#

interface Vlanif70

 ip address 192.168.70.2 255.255.255.0

#

interface Vlanif80

 ip address 192.168.80.2 255.255.255.0

#

interface MEth0/0/1

#

interface GigabitEthernet0/0/1

 port link-type trunk

 port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/2

 port link-type trunk

 port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/3

 port link-type trunk

 port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/4

 port link-type trunk

 port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/5

 port link-type trunk

 port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/6

 port link-type access

 port default vlan 70

#

interface GigabitEthernet0/0/7

 port link-type access

 port default vlan 80

#

ospf 1

 area 0.0.0.0

  network 192.168.70.0 0.0.0.255

  network 192.168.80.0 0.0.0.255

  network 192.168.40.0 0.0.0.255

  network 192.168.30.0 0.0.0.255

  network 192.168.20.0 0.0.0.255

  network 192.168.10.0 0.0.0.255

#

port-group 1

 group-member GigabitEthernet0/0/1

 group-member GigabitEthernet0/0/2

 group-member GigabitEthernet0/0/3

 group-member GigabitEthernet0/0/4

 

AR1(AR2220):

<Huawei>display current-configuration

#

acl number 2000 

 rule 5 permit

#

firewall zone Local

 priority 15

#

interface GigabitEthernet0/0/0

 ip address 192.168.50.1 255.255.255.0

#

interface GigabitEthernet0/0/1

 ip address 192.168.70.1 255.255.255.0

#

interface GigabitEthernet0/0/2

 ip address 100.0.0.1 255.0.0.0

 nat outbound 2000

#

ospf 1

 default-route-advertise

 area 0.0.0.0

  network 192.168.50.0 0.0.0.255

  network 192.168.70.0 0.0.0.255

#

ip route-static 0.0.0.0 0.0.0.0 100.0.0.10

#

AR2(AR2220):

<Huawei>display current-configuration

#

acl number 2000 

 rule 5 permit

#

interface GigabitEthernet0/0/0

 ip address 192.168.60.1 255.255.255.0

#

interface GigabitEthernet0/0/1

 ip address 192.168.80.1 255.255.255.0

#

interface GigabitEthernet0/0/2

 ip address 100.0.0.2 255.0.0.0

 nat outbound 2000

#

ospf 1

 default-route-advertise

 area 0.0.0.0

  network 192.168.60.0 0.0.0.255

  network 192.168.80.0 0.0.0.255

#

ip route-static 0.0.0.0 0.0.0.0 100.0.0.10

#

LSW7(S3700)

[Huawei]interface Vlanif 1

[Huawei-Vlanif1]ip address 100.0.0.10 8