PAT-A1067 Sort with Swap(0, i) 题目内容及题解
Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:
Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}
Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.
Input Specification:
Each input file contains one test case, which gives a positive N (≤10^5) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.
Output Specification:
For each case, simply print in a line the minimum number of swaps need to sort the given permutation.
Sample Input:
10
3 5 7 2 6 4 9 0 8 1
Sample Output:
9
题目大意
用交换的方式将给定的序列排序,要求输出最少的交换次数。
解题思路
使用贪心法计算交换次数:
- 读入序列,读入序列过程中记录有多少错位的元素;
- 开始交换过程,当0位置的元素为0时(恰在其位置),寻找到第一个错位的元素与0位置交换;
- 当0的位置不为0时,则交换0位置与当前0位置元素所应存放位置;
- 交换过程中计数,直到错位元素数为0;
- 输出结果并返回零值。
代码
#include<stdio.h>
#define maxn 100010
int pos[maxn];
void Swap(int a,int b){
int temp;
temp=pos[a];
pos[a]=pos[b];
pos[b]=temp;
}
int main(){
int N,left,count=0;
int i,v,k=0;
scanf("%d",&N);
left=N-1;
for(i=0;i<N;i++){
scanf("%d",&v);
pos[v]=i;
if(pos[i]==i&&i!=0){
left--;
}
}
while(left>0){
if(pos[0]==0){
while(k<N){
k++;
if(pos[k]!=k){
Swap(0,k);
count++;
break;
}
}
}else{
Swap(0,pos[0]);
count++;
left--;
}
}
printf("%d\n",count);
return 0;
}
运行结果