hdu 1698 Just a Hook 【线段树成段更新】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1698

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 44747    Accepted Submission(s): 21373


 

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
 

hdu 1698 Just a Hook 【线段树成段更新】hdu 1698 Just a Hook 【线段树成段更新】



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

 

 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

 

 

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample input

1
10
2
1 5 2
5 9 3

Sample output

Case 1: The total value of the hook is 24.

题意:Pudge可以把连续的金属棒从X数到Y数变成铜棒,银棒或金棒。该挂钩的总价值计算为N根金属棒的值之和,输出操作之后钩子的总价值。

分析:线段树的成段更新,直接套树解决。

AC代码如下:

#include<iostream>
#include<algorithm>
#include<string.h>
#define lson l,m,root<<1 //这是个小技巧
#define rson m+1,r,root<<1|1 //小技巧
using namespace std;
typedef long long ll;
const int maxn = 1e6+10;
ll add[maxn<<2]; //打懒标记
ll sum[maxn<<2]; //记录区间和
int n,m,a,b,c,cas=1;
char s[5];
void pushup(int root)
{
    sum[root] = sum[root<<1] + sum[root<<1|1];
}
void pushdown(int root,int m)
{
    if(add[root])
    {
        add[root<<1] = add[root];
        add[root<<1|1] = add[root];
        //修改子节点的Sum使之与对应的Add相对应
        sum[root<<1] = (m-(m>>1))*add[root];
        sum[root<<1|1] = (m>>1)*add[root];
        //清除本节点标记
        add[root] = 0; //标记向下传递完成的同时自身更新为0
    }
}
//建树操作,当递归到叶子节点的时候,输入题目要求的值进去
void build(int l,int r,int root)
{
    add[root] = 0;
    if(l==r)
    {
        sum[root] = 1;
        return;
    }
    int m = (l+r)>>1;
    build(lson);
    build(rson);
    pushup(root);
}
void update(int L,int R,int c,int l,int r,int root) //L,R为要操作的区间,l,r表示当前节点区间,root表示当前节点编号,下同
{
    if(L<=l && R>=r)
    {
        add[root] = c;
        sum[root] = c*(r-l+1);
        return ;
    }
    pushdown(root,r-l+1);
    int m = (l+r)>>1;
    //这里判断左右子树跟[L,R]有无交集,有交集才递归
    if(L<=m)
        update(L,R,c,lson);
    if(R>m)
        update(L,R,c,rson);
    pushup(root);
}
ll query(int L,int R,int l,int r,int root)
{
    if(L<=l && R>=r)
        return sum[root];
    //下推标记,否则Sum可能不正确
    pushdown(root,r-l+1);
    int m = (l+r)>>1;
    //下面是进行答案的累加
    ll ans = 0;
    if(L<=m)
        ans += query(L,R,lson);//左子区间与[L,R]有重叠,递归
    if(R>m)
        ans += query(L,R,rson);//右子区间与[L,R]有重叠,递归
    return ans;
}
int main()
{
    ios::sync_with_stdio(false);
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        build(1,n,1);
        while(m--)
        {
            cin>>a>>b>>c;
            update(a,b,c,1,n,1);
        }
        cout<<"Case "<<cas++<<": "<<"The total value of the hook is "<<query(1,n,1,n,1)<<'.'<<endl;
    }
    return 0;
}