链表节点的删除

师–链表的结点插入
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
给出一个只有头指针的链表和 n 次操作,每次操作为在链表的第 m 个元素后面插入一个新元素x。若m 大于链表的元素总数则将x放在链表的最后。

Input
多组输入。每组数据首先输入一个整数n(n∈[1,100]),代表有n次操作。

接下来的n行,每行有两个整数Mi(Mi∈[0,10000]),Xi。

Output
对于每组数据。从前到后输出链表的所有元素,两个元素之间用空格隔开。

Sample Input
4
1 1
1 2
0 3
100 4
Sample Output
3 1 2 4
Hint
样例中第一次操作1 1,由于此时链表中没有元素,1>0,所以此时将第一个数据插入到链表的最后,也就是头指针的后面。

Source
链表节点的删除

#include <stdio.h>
#include <stdlib.h>
struct st
{
int date;
struct st *next;
};
int main()
{
int n,m,x;
struct st *head,p,q;
while(scanf("%d",&n)!=EOF)
{
head=(struct st
)malloc(sizeof(struct st));
head->next=NULL;
while(n–)
{
scanf("%d%d",&m,&x);
p=head;
while(m–&&p->next!=NULL)
{
p=p->next;
}
q=(struct st
)malloc(sizeof(struct st));
q->date=x;
q->next=p->next;
p->next=q;
}
for(p=head->next;p!=NULL;p=p->next)
{
if(p->next==NULL)
printf("%d\n",p->date);
else
printf("%d ",p->date);
}
}
return 0;
}