EIGRP非等价负载均衡

 先看一下路由器的基本配置情况:

routerA:

interface Loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 152.1.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.1.1.1 255.255.255.0
 serial restart-delay 0
!
router eigrp 10
 network 10.0.0.0
 network 152.1.0.0
 network 192.1.1.0
 no auto-summary

routerB:

interface FastEthernet0/0
 ip address 152.1.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.1.1.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/2
 ip address 193.1.1.2 255.255.255.0
 serial restart-delay 0

router eigrp 10
 network 192.1.1.0
 network 193.1.1.0
 no auto-summary

routerC:

interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
      

interface Serial1/2
 ip address 193.1.1.3 255.255.255.0
 serial restart-delay 0

router eigrp 10
 network 3.0.0.0
 network 193.1.1.0
 no auto-summary

看一下路由器A的拓扑表到3.3.3.0有两个路径,因为下面的AD<FD,所以下面的路径为到3.3.3.0的FS

routerA#sh ip eigrp topology detail-links
IP-EIGRP Topology Table for AS(10)/ID(1.1.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 3.3.3.0/24, 1 successors, FD is 2300416, serno 30, Stats m(152)M(152)A(152)c(1)
        via 152.1.1.2 (2300416/2297856), FastEthernet0/0
        via 192.1.1.2 (2809856/2297856), Serial1/0

P 152.1.1.0/24, 1 successors, FD is 28160, serno 1
        via Connected, FastEthernet0/0
        via 192.1.1.2 (2172416/28160), Serial1/0
P 192.1.1.0/24, 1 successors, FD is 2169856, serno 2
        via Connected, Serial1/0
        via 152.1.1.2 (2172416/2169856), FastEthernet0/0
P 193.1.1.0/24, 1 successors, FD is 2172416, serno 8
        via 152.1.1.2 (2172416/2169856), FastEthernet0/0
        via 192.1.1.2 (2681856/2169856), Serial1/0

路由表中只有一条路由

routerA#sh ip route 3.3.3.0
Routing entry for 3.3.3.0/24
  Known via "eigrp 10", distance 90, metric 2300416, type internal
  Redistributing via eigrp 10
  Last update from 152.1.1.2 on FastEthernet0/0, 00:08:15 ago
  Routing Descriptor Blocks:
  * 152.1.1.2, from 152.1.1.2, 00:08:15 ago, via FastEthernet0/0
      Route metric is 2300416, traffic share count is 1
      Total delay is 25100 microseconds, minimum bandwidth is 1544 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2

routerA#sh ip rou
routerA#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     152.1.0.0/24 is subnetted, 1 subnets
C       152.1.1.0 is directly connected, FastEthernet0/0
     3.0.0.0/24 is subnetted, 1 subnets
D       3.3.3.0 [90/2300416] via 152.1.1.2, 00:08:35, FastEthernet0/0
D    193.1.1.0/24 [90/2172416] via 152.1.1.2, 00:08:35, FastEthernet0/0
C    192.1.1.0/24 is directly connected, Serial1/0

下面添加一条variance命令,取值范围1-128,默认为1。

routerA(config)#router eigrp 10
routerA(config-router)#variance 2

非等价负载均衡路径首先必须是路由的FS,然后FD要小于successor的FD*variance值。当然,最多不能超过6条,默认为4条。

routerA#sh ip route
Gateway of last resort is not set

     152.1.0.0/24 is subnetted, 1 subnets
C       152.1.1.0 is directly connected, FastEthernet0/0
     3.0.0.0/24 is subnetted, 1 subnets
D       3.3.3.0 [90/2809856] via 192.1.1.2, 00:08:53, Serial1/0
                       [90/2300416] via 152.1.1.2, 00:08:53, FastEthernet0/0
D    193.1.1.0/24 [90/2681856] via 192.1.1.2, 00:08:53, Serial1/0
                  [90/2172416] via 152.1.1.2, 00:08:53, FastEthernet0/0
C    192.1.1.0/24 is directly connected, Serial1/0