Subsequence(尺取)

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

题意:

给定一个序列a[]和一个maxs,求不小于maxs的子序列的长度最小值

解析:

Subsequence(尺取)

最简单尺取

求从左到右得一个>=maxs的子序列,然后减掉末尾的呢个,再看前面需要加几个(包括0)可以和>=maxs,直到前面加不了为止,结束

ac:

#include<cstdio>
#include<algorithm>
#define ll long long
#define MAXN 100005
using namespace std;
int a[MAXN];

int main()
{
    int t,maxs,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&maxs);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        ll sum=0;
        int i=0,j=0;
        int ans=99999999;
        while(1)
        {
            while(sum<maxs&&j<n)
                sum+=a[j],j++;
            if(sum<maxs)
                break;
            ans=min(ans,j-i);
            sum-=a[i],i++;
        }
        if(ans==99999999)
            printf("0\n");
        else printf("%d\n",ans);
    }
    return 0;
}