poj1390

Blocks
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 5713   Accepted: 2356

Description

Some of you may have played a game called 'Blocks'. There are n blocks in a row, each box has a color. Here is an example: Gold, Silver, Silver, Silver, Silver, Bronze, Bronze, Bronze, Gold. 
The corresponding picture will be as shown below: 
poj1390 
Figure 1

If some adjacent boxes are all of the same color, and both the box to its left(if it exists) and its right(if it exists) are of some other color, we call it a 'box segment'. There are 4 box segments. That is: gold, silver, bronze, gold. There are 1, 4, 3, 1 box(es) in the segments respectively. 

Every time, you can click a box, then the whole segment containing that box DISAPPEARS. If that segment is composed of k boxes, you will get k*k points. for example, if you click on a silver box, the silver segment disappears, you got 4*4=16 points. 

Now let's look at the picture below: 
poj1390 
Figure 2


The first one is OPTIMAL. 

Find the highest score you can get, given an initial state of this game. 

Input

The first line contains the number of tests t(1<=t<=15). Each case contains two lines. The first line contains an integer n(1<=n<=200), the number of boxes. The second line contains n integers, representing the colors of each box. The integers are in the range 1~n.

Output

For each test case, print the case number and the highest possible score.

Sample Input

2
9
1 2 2 2 2 3 3 3 1
1
1

Sample Output

Case 1: 29
Case 2: 1

AC代码:

#include<cstdio>
#include<string.h>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
int len[205],dp[205][205][205],color[205];
int DP(int x,int y,int k)
{
        if(dp[x][y][k])
                return dp[x][y][k];
        if(x==y)
                return (len[x]+k)*(len[x]+k);
        dp[x][y][k]=DP(x,y-1,0)+(len[y]+k)*(len[y]+k);
        for(int i=x;i<y;i++)
        {
                if(color[y]==color[i])
                {
                        dp[x][y][k]=max(dp[x][y][k],DP(x,i,len[y]+k)+DP(i+1,y-1,0));
                }
        }
        return dp[x][y][k];
}
int main()
{
        int t;
        scanf("%d",&t);
        for(int r=1;r<=t;r++)
        {
                int n;
                scanf("%d",&n);
                int num=0;
                memset(len,0,sizeof(len));
                memset(color,0,sizeof(color));
                for(int i=1;i<=n;i++)
                {
                        int temp;
                        scanf("%d",&temp);
                        if(color[num]==temp)
                                len[num]++;
                        else
                        {
                                num++;
                                len[num]++;
                                color[num]=temp;
                        }
                }
                memset(dp,0,sizeof(dp));
                int ans=DP(1,num,0);
                printf("Case %d: ",r);
                printf("%d\n",ans);
        }
        return 0;
}