HDU2560 Buildings【水题】

Buildings

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4627 Accepted Submission(s): 3824

Problem Description
We divide the HZNU Campus into NM grids. As you can see from the picture below, the green grids represent the buidings. Given the size of the HZNU Campus, and the color of each grid, you should count how many green grids in the NM grids.

HDU2560 Buildings【水题】

Input
Standard input will contain multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
The first line of each test case contains two integers n and m(1<=n,m<=100), the size of the campus. Then follow n lines, each line containing m integers. The j-th integer in the i-th line is the color of that grid, 0 stands for white color, while 1 stands for green.

Output
Results should be directed to standard output. For each case, output an integers T, the total green grids in the N*M size campus.

Sample Input
2
2 2
1 1
0 0
3 3
1 0 1
0 0 1
1 1 0

Sample Output
2
5

Source
2008 HZNU Programming Contest

问题链接HDU2560 Buildings
问题简述:(略)
问题分析
    统计矩阵中1的个数,大水题。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C语言程序如下:

/* HDU2560 Buildings */

#include <stdio.h>

int main(void)
{
    int t, n, m, a, i, j;
    scanf("%d", &t);
    while(t--) {
        scanf("%d%d", &n, &m);
        int cnt = 0;
        for(i = 1; i <= n; i++)
            for(j = 1; j <= m; j++) {
                scanf("%d", &a);
                if(a) cnt++;
            }
        printf("%d\n", cnt);
    }

    return 0;
}