PAT-A1031 Hello World for U 题目内容及题解

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h    d
e     l
l      r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h      !
e     d
l       l
lowor

题目大意

题目给出一个字符串,将其排成U型并输出。

解题思路

  1. 计算排列成U型的计算参数;
  2. 按参数将原字符串输出,并返回0值。

代码

#include<stdio.h>
#include<string.h>

int main(){
    char ch[90];
    int len,i,j,k;
    int n1,n2;
    scanf("%s",ch);
    len=strlen(ch);
    i=0;
    j=len-1;
    n1=(len+2)/3;//高度 
    n2=len-2*n1+2;//宽度 
    while(--n1){
        k=n2-2;
        printf("%c",ch[i]);
        i++;
        while(k--){
            printf(" ");
        }
        printf("%c\n",ch[j]);
        j--;
    }
    while(i<=j){
        printf("%c",ch[i++]);
    }
    printf("\n");
    return 0;
}

运行结果

PAT-A1031 Hello World for U 题目内容及题解