PAT-A1053 Path of Equal Weight 题目内容及题解

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

PAT-A1053 Path of Equal Weight 题目内容及题解

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题目大意

题目给定一个非空加权树,从R到L的路径的权值被定义为从R到任意叶节点L的路径上所有节点的权值之和。题目要求找到所有权值等于给定数字的路径。

解题思路

  1. 使用邻接表保存树,并将节点的子结点按照权值大小进行排序;
  2. 采用DFS遍历,并对不合适的路径进行剪枝,并将合适的路径按照题目要求输出;
  3. 返回零值。

代码

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;

struct Node{
    int data;
    vector<int> children;
}node[110];
int N,M,S;
int temp[110];

bool cmp(int i,int j){
    return node[i].data>node[j].data;
}

void DFS(int root,int depth,int sum){
    int i;
    temp[depth]=node[root].data;
    sum+=node[root].data;
    if(sum>S){
        return;
    }
    if(sum==S){
        if(node[root].children.size()!=0){
            return;
        }
        for(i=0;i<=depth;i++){
            printf("%d",temp[i]);
            if(i<depth){
                printf(" "); 
            }else{
                printf("\n");
            }
        }
        return;
    }
    for(i=0;i<node[root].children.size();i++){
        DFS(node[root].children[i],depth+1,sum);
    }
}

int main(){
    int i;
    int id,num,k;
    scanf("%d%d%d",&N,&M,&S);
    for(i=0;i<N;i++){
        scanf("%d",&node[i].data);
    }
    for(i=0;i<M;i++){
        scanf("%d%d",&id,&num);
        while(num--){
            scanf("%d",&k);
            node[id].children.push_back(k);
        }
        sort(node[id].children.begin(),node[id].children.end(),cmp);
    }
    DFS(0,0,0);
    return 0;
}

运行结果

PAT-A1053 Path of Equal Weight 题目内容及题解