1053 Path of Equal Weight

1053 Path of Equal Weight (30 分)

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from Rto L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

1053 Path of Equal Weight

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains Npositive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
#include<bits/stdc++.h>
using namespace std;

typedef struct MyStruct{
	int weight;
	vector<int>child;
	int last,length;
}node;
int temp,ct,cd,n, m, s,it;
vector<int> f,path;
vector<node>tree;
vector<vector<int>>pathset;

bool cmp(int a,int b) {
	return tree[a].weight >tree[b].weight;
}

void find_path(int i){
	if (tree[i].last != -1)find_path(tree[i].last);
	path.push_back(i);
}

void dfs(int i) {
	if (tree[i].length > s) {
		tree[i].child = vector<int>();
		return;
	}
	if (tree[i].child.size() == 0 && tree[i].length == s) {
		path = vector<int>();
		find_path(i);
		pathset.push_back(path);
	}
	if (tree[i].child.size() != 0)
		for (int j = 0; j < tree[i].child.size(); j++) {
			int chd = tree[i].child[j];
			tree[chd].length = tree[i].length + tree[chd].weight;
			dfs(chd);
		}
}

int main() {
	cin >> n >> m >> s;
	tree=vector<node>(n, {0,f,-1,-1});
	vector<bool>findroot(n,1);
	for (int i = 0; i < n; i++)cin >> tree[i].weight;
	for (int i = 0; i < m; i++) {
		cin >> temp>>ct;
		for (int j = 0; j < ct; j++) {
			cin >> cd;
			findroot[cd] = 0;
			tree[temp].child.push_back(cd);
			tree[cd].last = temp;
		}
	}
	for (int i = 0; i < n; i++)if (tree[i].child.size() > 1)
		sort(tree[i].child.begin(), tree[i].child.end(),cmp);
	for (; it < n; it++)if (findroot[it] == 1)break;
	tree[it].length = tree[it].weight;
	dfs(it);
	for (int i = 0; i < pathset.size(); i++) {
		printf("%d", tree[pathset[i][0]].weight);
		for (int j = 1; j < pathset[i].size(); j++)printf(" %d", tree[pathset[i][j]].weight);
		printf("\n");
	}
	return 0;
}