PAT A1053 Path of Equal Weight

1053 Path of Equal Weight (30 分)

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

PAT A1053 Path of Equal Weight

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

求 叶子结点的带权路径和(即从根结点到叶子结点的路径上的结点点权之和) 为指定值的 路径 (输出权值序列)

慢慢写,好好学数据结构,好好看算法笔记,30分答题也不过如此。但要练速度了

#include<iostream>
#include <algorithm>
#include<queue>
#include<vector>
using namespace std;

const int maxn=110;
int n,m,S;

struct node{
	int weight;
	vector<int> child;
	// vector<int> path;//走到当前结点的路径
}Node[maxn];

//子结点按从大到小排序
bool cmp(int a,int b){
	return Node[a].weight>Node[b].weight;//按权值从大到小排序
}

//当前遍历到root结点  当前累加总权重为sumW  走到当前结点的路径
void DFS(int root,int sumW,vector<int> path){
	//访问当前结点
	path.push_back(root);
	sumW+=Node[root].weight;

	//判断下一步
	if(sumW>S){
		return;
	}else if(sumW==S){
		if(Node[root].child.size()==0){//到叶了才行
			cout<<Node[0].weight;
			for(int i=1;i<path.size();i++){
				cout<<" "<<Node[path[i]].weight;
			}
			cout<<endl;
		}
		return;
	}else{
		//深搜子结点  长度为0 到叶子了 下面没代码了 也return了
		for(int i=0;i<Node[root].child.size();i++){
			DFS(Node[root].child[i],sumW,path);
		}
	}
}

int main(){
	// freopen("input.txt","r",stdin);
	cin>>n>>m>>S;
	for(int i=0;i<n;i++){
		cin>>Node[i].weight;
	}

	int x,num,nt;
	for(int i=0;i<m;i++){
		cin>>x>>num;
		for(int j=0;j<num;j++){
			cin>>nt;
			Node[x].child.push_back(nt);
		}
		sort(Node[x].child.begin(),Node[x].child.end(),cmp);//按权值从大到小排序后插入
	}
	vector<int> path;
	DFS(0,0,path);
	return 0;
}