PAT 甲级 1053  Path of Equal Weight

1053 Path of Equal Weight (30 point(s))

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

PAT 甲级 1053  Path of Equal Weight

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

经验总结:

这一题,关键点在于排序问题,你可以在DFS中收集,收集完之后统一进行排序,但也可以在输入时就对每个非叶节点的所有孩子进行排序,这样收集到的权值就已经是有序的了, 其他的就是DFS的判断返回问题,可以在权值和大于给定目标值时立刻返回,这样可以节约一些时间,其他的就没有什么啦~~

AC代码

#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
struct node
{
	int no,weight;
	vector<int> child;
}Node[110];
int s;
vector<int> temp;
bool cmp(int a,int b)
{
	return Node[a].weight>Node[b].weight;
}
void DFS(int x,int sum)
{
	if(sum>s||sum==s&&Node[x].child.size()>0)
		return ;
	if(Node[x].child.size()==0&&sum==s)
	{
		temp.push_back(x);
		for(int i=0;i<temp.size();++i)
		{
			printf("%d",Node[temp[i]].weight);
			if(i<temp.size()-1)
				printf(" ");
			else
				printf("\n");
		}
		temp.pop_back();
		return ;
	}
	temp.push_back(x);
	for(int i=0;i<Node[x].child.size();++i)
	{
		DFS(Node[x].child[i],sum+Node[Node[x].child[i]].weight);
	}
	temp.pop_back();
}
int main()
{
	int n,m,k,no,t;
	scanf("%d %d %d",&n,&m,&s);
	for(int i=0;i<n;++i)
	{
		scanf("%d",&Node[i].weight);
	}
	for(int i=0;i<m;++i)
	{
		scanf("%d %d",&no,&k);
		for(int j=0;j<k;++j)
		{
			scanf("%d",&t);
			Node[no].child.push_back(t);
		}
		sort(Node[no].child.begin(),Node[no].child.end(),cmp);
	}
	DFS(0,Node[0].weight);
	return 0;
}