HDU3336 KMP

题目链接

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14549    Accepted Submission(s): 6656


 

Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

 

 

Input

The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

 

 

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

 

 

Sample Input

 

1 4 abab

 

 

Sample Output

 

6

这题主要考KMP

abab对它进行预处理

 

HDU3336 KMP

 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 200005
char p[N],t[N];
int nexts[N];
void getNext()
{
    int i=0;
    int j=-1;
    nexts[0]=-1;
    int len=strlen(p);
    while(i<len)
    {
        if(j==-1||p[j]==t[i])
        {
            i++;
            j++;
            nexts[i]=j;
        }
        else j=nexts[j];
    }
}
int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        int num;
        cin>>num;
        cin>>p;
        strcpy(t,p);
        getNext();
        int sum=0;
        for(int i=1;i<=num;i++)
            if(nexts[i])sum++;
        sum+=num;
        sum%=10007;
        cout<<sum<<endl;
    }
    return 0;
}