hdu2602 01背包
基本的背包问题,掉了一个dp【v】的情况
Bone Collector
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 75979 Accepted Submission(s): 31486
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14
#include<bits/stdc++.h>
using namespace std;int bonesval[1003],bonesV[1003],dp[1003];
int main()
{
int t,i,j,n,v;
cin>>t;
while(t--)
{
memset(bonesval,0,sizeof(bonesval));
memset(bonesV,0,sizeof(bonesV));
memset(dp,0,sizeof(dp));
cin>>n>>v;
for(i=0; i<n; ++i)
{
cin>>bonesval[i];
}
for(i=0; i<n; ++i)
cin>>bonesV[i];
for(i=0; i<=n; ++i)
{
for(j=v; j>=0; --j)
{
if(j-bonesV[i]>=0)
dp[j]=max(dp[j],dp[j-bonesV[i]]+bonesval[i]);
//cout<<"dp["<<i<<"]["<<j<<"]=="<<dp[v]<<endl;
// cout<<dp[j];
}
//printf("\n");
}
int tol=0;
for(i=0; i<=v; ++i)
{
if(dp[i]>=tol)
tol=dp[i]; //掉了个v
}
cout<<tol<<endl;
}
return 0;
}