PAT甲级-1053 Path of Equal Weight (dfs)

1053 Path of Equal Weight (30 分)

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

PAT甲级-1053 Path of Equal Weight (dfs)

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

//题意,给你n个节点,m个非叶子结点,以及一个数s;再给你每个节点的权重,再给你每个非叶子节点的儿子的 编号;

要求你从根节点(规定是00)出发,叶子节点为止,找出权重为s的路,并从根节点开始输出该路上的节点的权重;如果有多条,则按照以下规则输出:如果有A:{a1,a2,a3...},B:{b1,b2,b3...}两条路;如果a1>b1,先输出A,若a1==b1,a2>b2,先输出A,类似于strcmp(s1,s2)两字符串的比较规则;

//错误思路:对一个父节点的每个子节点按照权重递增建树;然后bfs;这样的话实际上是最短路(遍历的节点数)优先,路程相等的情况下,才是权重大的节点优先;栗子:{10,4,10}会优先于{10,5,2,7}先输出;

//正确思路:对一个父节点的每个子节点按照权重递增建树;然后dfs;

//其他错误见代码;

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;
struct Node
{
    int id;
    int val;
    int before;//记录前一个节点的id;
    int sum;
    Node()
    {
        sum=0;
        before=-1;
    }
};
bool cmp(Node A,Node B)
{
    return A.val>B.val;
}
vector<int>edge[105];
vector<int>ans;
Node node[105];
int vis[105];
int n,m,s;
void dfs(int k)
{
    if(node[k].sum==s)
    {
        if(edge[k].size()!=0)
            return;
        ans.clear();
        ans.push_back(node[k].val);
        int now=node[k].before;
        while(now!=-1)
        {
            ans.push_back(node[now].val);
            now=node[now].before;
        }
        for(int i=ans.size()-1;i>=0;i--)
        {
            printf("%d",ans[i]);
            if(i==0)printf("\n");
            else printf(" ");
        }
        return ;
    }else if(node[k].sum>s)
    {
         
        return;
    }else
    {
         
        for(int i=0;i<edge[k].size();i++)
        {
            int tt=edge[k][i];
            
            if(vis[tt]==0)
            {
                vis[tt]=1;
                node[tt].sum=node[tt].val+node[k].sum;
                node[tt].before=k;
                dfs(tt);
                vis[tt]=0;
                node[tt].sum=node[tt].val;
                node[tt].before=-1;
            }
        }
    }
    return ;
}
int main()
{
    memset(vis,0,sizeof(vis));
    scanf("%d%d%d",&n,&m,&s);
    for(int i=0;i<n;i++)
    {
        int x;
        scanf("%d",&x);
        node[i].val=x;
        node[i].id=i;
        node[i].sum=x;
    }
    Node a[105];
    for(int i=0;i<m;i++)
    {
        int k,cn;
        scanf("%d%d",&k,&cn);
        int index;
        for(int j=0;j<cn;j++)
        {
            scanf("%d",&index);
            a[j]=node[index];
        }
        sort(a,a+cn,cmp);//wrong:刚开始直接拿node[index]进行排序,这样排完之后index就不等于该节点的编号了,所以出错;
        for(int j=0;j<cn;j++)
        {
            edge[k].push_back(a[j].id);
        }
    }
    vis[0]=1;
    dfs(0);
    return 0;
}