HDU2084 数塔问题 简单线性规划

HDU2084 数塔问题 简单线性规划

题目来源:http://acm.hdu.edu.cn/webcontest/contest_showproblem.php?pid=1003&ojid=0&cid=13029&hide=0

在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?
HDU2084 数塔问题 简单线性规划
已经告诉你了,这是个DP的题目,你能AC吗?

Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。

Output
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。

Sample Input
1
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30

解题思路:使用线性规划,只需要比较dp(dp[i-1][j-1],与dp[i-1][j]的大小就objk了

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <cstring>
using namespace std;

int main()
{
    int c,n,d[105][105];
    int dp[105][105];
    cin >> c;
    while(c--)
    {
        memset(dp,0,sizeof(dp));///重点啊,因为是多组测试,一定要记得写这个,我每次都忘记囧
        memset(d,0,sizeof(d));
        cin >> n;
        for(int i=1;i<=n;i++)
        {
           for(int j=1;j<=i;j++)
           {
               cin >> d[i][j];
           }
        }
         int ans=0;
        for(int i=1;i<=n;i++)
        {
           for(int j=1;j<=i;j++)
           {
               dp[i][j]=max(dp[i-1][j-1],dp[i-1][j])+d[i][j];
           }
        }
        for(int i=1;i<=n;i++)
        {
            ans=max(ans,dp[n][i]);
        }
        cout << ans << endl;
    }
    return 0;
}

来源:https://i.****.net/